Reseller customer users in UM 2.0 see data up to July 9th

Incident Report for Umbrella Cost

Resolved

The incident is resolved.
Posted Jul 13, 2026 - 15:58 UTC

Monitoring

A fix was deployed and we are monitoring the outcome
Posted Jul 13, 2026 - 12:27 UTC

Identified

Data updates to reseller customer users are stopped on July 9th.
There is no data loss, this is only a display glitch.
The issue has been identified and fix is being implemented.
Posted Jul 13, 2026 - 08:48 UTC
This incident affected: Generic Functionality (Cost Explorer, Dashboards & Reports, Recommendations Engine, Users interface and API, Anomaly Detection & Monitoring, Kubernetes, Reports, MSPs Rebilling, Budget Administraction).