Dashboards get stuck in loading

Incident Report for Umbrella Cost

Resolved

Issue was resolved and after monitoring for 24 hours closing the incident
Posted Jan 25, 2026 - 08:36 UTC

Monitoring

We have identified the issue and issued a fix, checking the impact and validating there are no other issues.
Posted Jan 22, 2026 - 12:38 UTC

Update

We are continuing to investigate this issue.
Posted Jan 22, 2026 - 10:11 UTC

Investigating

In some cases the dashboard loading is stuck - we are investigating if the root cause is related to upgrades on the system done during this week and will update soon.
Posted Jan 22, 2026 - 10:11 UTC
This incident affected: Generic Functionality (Cost Explorer, Dashboards & Reports).