Recommendation close state issue

Incident Report for Umbrella Cost

Resolved

Incident closed and data is restored.
Posted Mar 22, 2025 - 13:53 UTC

Update

While 95% of all customers are all good for 12 hours now, we have found some that require additional restoration, keeping this open until we're full restored and validated.
Posted Mar 20, 2025 - 15:55 UTC

Monitoring

Issue has been fixed and data restored for most of the accounts, we are monitoring the state and will update once all accounts are back to the same state prio to closing some of the recommendations.
Posted Mar 19, 2025 - 22:35 UTC

Identified

An improvement in our recommendation logic had a flaw causing a some recommendation to close although their state should have stayed open. Issue start time is 18/3 20:00.
We have identified the issue, hotfix will be deployed in the next hour, recommendation state will be restored completely until the end of the day.
Posted Mar 19, 2025 - 15:22 UTC
This incident affected: Generic Functionality (Recommendations Engine).