Invoices Processing Delays

Incident Report for Umbrella Cost

Resolved

This incident has been resolved.
Posted Oct 05, 2025 - 06:15 UTC

Identified

Umbrella is experiencing delays in invoices processing, our team is working on improving the system capacity to reduce the delay during the short period on which both previous and current month are processing at the same time.
Posted Oct 02, 2025 - 18:07 UTC
This incident affected: AWS Cloud Cost (AWS Invoices processing), GCP Cloud Cost (GCP Invoice processing), and Azure Cloud Cost (Azure Invoices processing).