Umbrellacost is experiencing invoices processing delays

Incident Report for Umbrella Cost

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 19:15 UTC

Monitoring

Umbrella invoice processing is experiencing delays as a result of data infrastructure deficiencies. Invoices might be delayed and we are currently favoring finishing May invoices over completing June latest.
System is recovering and is expected to be back on track within 12-24 hours.
Posted Jun 02, 2026 - 19:38 UTC
This incident affected: AWS Cloud Cost (AWS Invoices processing), GCP Cloud Cost (GCP Invoice processing), and Azure Cloud Cost (Azure Invoices processing).