Invoices Processing Delays as a result of AWS lack of capacity and EC2 delays

Incident Report for Umbrella Cost

Resolved

Incident is now closed and all services are operating.
Posted Oct 21, 2025 - 10:13 UTC

Update

All of our services are back to normal operation but as AWS infrastructure reporting and monitoring were not fully back up we'll continue monitoring
Posted Oct 21, 2025 - 07:37 UTC

Update

Redshift seems to be back, we're restoring invoice processing and continue to monitor
Posted Oct 20, 2025 - 22:24 UTC

Update

Note that AWS Redshift services went down which is impacting our ability to onboard new accounts from any cloud provider.
Posted Oct 20, 2025 - 14:56 UTC

Update

AWS still have issues launching and terminating instances and hence although all services are up we cannot process invoices in the rate required - we are with AWS representatives to prioritize our needs.
Posted Oct 20, 2025 - 12:53 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 12:04 UTC

Monitoring

AWS us-east-1 region on which most of our backend services operate still experience delays and lack of EC2 resources, we are monitoring and will update once we can fully reprocess invoices from the last 24 hours.
Posted Oct 20, 2025 - 12:04 UTC
This incident affected: AWS Cloud Cost (AWS Invoices processing, AWS onboarding), Azure Cloud Cost (Azure On-boarding, Azure Invoices processing), GCP Cloud Cost (GCP Onboarding, GCP Invoice processing), and Generic Functionality (Anomaly Detection & Monitoring).