Onboarding new accounts Fails

Incident Report for Umbrella Cost

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 20:12 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Onboarding may be initiated on all Cloud providers
Posted Apr 27, 2026 - 13:07 UTC

Investigating

We are experiencing failures in onboarding new accounts to the umbrella platform.
We are investigating the problem and will issue updates as we find the root cause.

Processing of existing accounts is fully operational.
Posted Apr 27, 2026 - 07:54 UTC
This incident affected: Azure Cloud Cost (Azure On-boarding), GCP Cloud Cost (GCP Onboarding), and AWS Cloud Cost (AWS onboarding).