90% of March invoices were re-processed fixing the amortization issue and we expect to complete it in the next 2-3 hours.
Posted Apr 03, 2025 - 07:50 UTC
Update
Fixed the root cause of the issue, running additional validations on test accounts in the next 20-30 minutes and then we'll re-run all AWS invoices that were processed during the last 24 hours.
Posted Apr 02, 2025 - 08:52 UTC
Update
We are experiencing a delay in the invoice processing for the AWS account. Additionally, we have identified an issue with the amortization of AWS costs, which is now being resolved. The Net Amortized and Amortized views data will be fully restored within the next 24 hours.
Posted Apr 02, 2025 - 08:24 UTC
Identified
We are experiencing invoice processing delays, which affects MSP's
Posted Apr 02, 2025 - 07:12 UTC
This incident affects: Generic Functionality (Cost Explorer, Dashboards & Reports) and AWS Cloud Cost (AWS Invoices processing).