Anodot is experiencing invoices processing delays

Incident Report for Umbrella Cost

Monitoring

Invoice processing is now back to normal and we assume all December invoices will catch up by end of the day.
Posted Dec 04, 2025 - 07:57 UTC

Identified

Our data processing infrastructure is running behind which is causing delay in updating invoice data in the reporting and alerting tools.

No data has been lost and we're working on catching up invoices processing, we are prioritizing processing November data before catching up with December updates.
Posted Dec 01, 2025 - 21:47 UTC
This incident affects: AWS Cloud Cost (AWS Invoices processing), GCP Cloud Cost (GCP Invoice processing), Azure Cloud Cost (Azure Invoices processing), and Generic Functionality (Kubernetes, Reports).