Umbrella is experiencing invoices processing delays

Incident Report for Umbrella Cost

Resolved

Invoice processing has resumed normal handling
Posted Aug 06, 2026 - 05:28 UTC

Identified

Our data processing infrastructure is running behind which is causing delay in updating invoice data in the reporting and alerting tools.

No data has been lost and we're working on catching up invoices processing.
Posted Aug 02, 2026 - 06:11 UTC
This incident affected: AWS Cloud Cost (AWS Invoices processing), GCP Cloud Cost (GCP Invoice processing), and Azure Cloud Cost (Azure Invoices processing).