Anodot is experiencing invoices processing delays

Incident Report for Umbrella Cost

Resolved

Incident has been resolved and all invoices processing is now back to normal

Root cause is based on file-system issues which were identified in an underline data system which slowed down invoices processing.
Posted Nov 29, 2025 - 17:53 UTC

Monitoring

Issue is now mitigated and we expect all processing to be back to normal in the next 6-7 hours. There could be still delays in accounts that have K8S clusters cost processing.
Posted Nov 28, 2025 - 20:16 UTC

Identified

Our data processing infrastructure is running behind which is causing delay in updating invoice data in the reporting and alerting tools.

No data has been lost and we're working on catching up invoices processing.
Posted Nov 28, 2025 - 14:50 UTC
This incident affected: AWS Cloud Cost (AWS Invoices processing), Generic Functionality (Recommendations Engine, Kubernetes, Reports), GCP Cloud Cost (GCP Invoice processing), and Azure Cloud Cost (Azure Invoices processing).