Umbrellacost is experiencing invoices processing delays

Incident Report for Umbrella Cost

Resolved

Incident was resolved 24hr ago - kept monitoring to validate processing for the billing period.
Posted Mar 05, 2026 - 07:13 UTC

Update

Issue root cause has been handled a few hours back and the system is working on the queued invoices.
Posted Feb 27, 2026 - 22:46 UTC

Monitoring

Our data processing infrastructure is running behind which is causing delay in updating invoice data in the reporting and alerting tools.

No data has been lost and we're working on catching up invoices processing.

ETA to processing of delayed invoices is up to 16 hours
Posted Feb 27, 2026 - 17:11 UTC
This incident affected: AWS Cloud Cost (AWS Invoices processing, AWS Kubernetes processing), GCP Cloud Cost (GCP Invoice processing), and Azure Cloud Cost (Azure Invoices processing).