AWS report they have found and fixed the billing processing issue. Umbrella continues to be fully operational.
We are monitoring the updated invoices and from our review, the data seems to be in order.
If you experience data related issues, please reach out to our support team.
Posted Jul 19, 2026 - 06:54 UTC
Update
Umbrella continue to monitor our input delays, currently it seems that AWS are catching up as most of currently running July invoices data is on the 18th. We will keep on monitoring for any issue. Latest update from AWS: We continue to make substantial progress toward resolving the issue affecting estimated cost and usage data displayed in the Billing and Cost Management Console. Our mitigation efforts are working as expected and we are seeing an increasing number of accounts reflecting correct cost and usage data. We expect all affected accounts to be fully recovered by July 19, 12:00 AM PDT. Until the backfill is complete, some customers may still observe incorrect cost and usage data in the Billing and Cost Management Console and Cost and Usage Reports. These estimates do not reflect actual usage or charges. We will provide another update by July 18, 7:00 AM PDT, or sooner if additional information becomes available.
Posted Jul 18, 2026 - 08:27 UTC
Monitoring
Note there is currently AWS billing issue at AWS. The umbrella processes and platform are fully operational during that period.
View the link from AWS describing the possible impact known right now.