K8s User interface and API issues

Incident Report for Umbrella Cost

Resolved

The incident has been resolved.
Platform fully operational.
Posted Mar 12, 2026 - 17:10 UTC

Monitoring

Issue has been mitigated - we're validating there are no leftovers
Posted Mar 12, 2026 - 17:04 UTC

Investigating

We're experiencing issues in our K8s web-application data visualization.

We're working on restoring the service ASAP.
Posted Mar 12, 2026 - 14:17 UTC
This incident affected: Generic Functionality (Cost Explorer, Dashboards & Reports, Users interface and API, Kubernetes).